Skocz do zawartości


Zdjęcie
- - - - -

[GUIDE][ANDROID] Zmodowany Play store i LP - wynik core.jar nie spaczowany


  • Zaloguj się, aby dodać odpowiedź
10 odpowiedzi w tym temacie

#1 chri5

chri5

    Junior Member

  • 28 postów

Napisano 31 marzec 2015 - 12:06

Jeśli źle i nie w tym miejscu ulokowałem temat, przepraszam i proszę o przeniesienie.

 

Może ktoś powie, że to nie nowość lub że to już było lecz to mój pierwszy taki przypadek z GP, a wcześniej instalowałem już masę razy bez problemu.

Sprawa dotyczy GP + LP na 4.4.x  = monit w LP, że core.jar nie spaczowany itp., więc możliwe, że pomoże komuś to co mi po długim czasie walki pomogło. Z góry z resztą napiszę, że może zdażyć się tak, że na jakimś innym rom'ie 4.4 i ten sposób zawiedzie lecz to jest jedyny jakim udało mi się poprawnie zainstalować modowany Play Store w SlimKat 4.4.4  9.0 OFFICIAL 8302 na Note 2 (N 7100) :)

 

To jest kontynuacja rozwiązania mojego problemu, który przedstawiłem tu  Modowany Play Store nie działa prawidłowo - w Lucky Patcher core.jar nie spatchowany

 

Sprawdzałem na wszystkie dosłownie sposoby łącznie z ręcznym patch'owaniem core.jar, podmiankami i instalacją sklepu przez LP. Przewaliłem stos przeróżnych wersji. Nic nie działało (jak wyżej z reszta opisałem).
Sposobem poniżej robiłem na innych wersjach installer'a i...o dziwo rownież nic z tego nie wychodziło.


Sposób dzięki któremu w końcu wszystko jest jak trzeba :) (sprawdzony dwukrotnie)

Tak dla wiadomości:
- Starego sklepu, który był już w rom'ie nie odinstalowywałem.
- Wiadomo, że cały proces trzeba zacząć od "czystego marketu", tak jak wygląda w nowo wgranym rom'ie.
Ja robiłem wszystko na czystym nowo postawionym rom'ie.

1. Lucky Patcher - instalacja (ja używałem tego LP.zip )
    + aktualizacja patcher'a do najnowszej wersji + "Download custom patches" (nic nie patch'ujemy !!!)
2. Instalacja installer'a Play Store z GPI 5.3.6.zip (jak zwykły apk)
3. Restart
4. Utworzenie konta Google
5. Instalcja GP w wersji 5.3.6 w installer'ze
6. Restart.

Póżniej pozostaje tylko dla formalności sprawdzenie czy:
- plik pod nazwą "Phonesy.apk" widnieje w system /priv-app
  (a nie tak jak w innych przypadkach pod inną nazwą w system/app bądz system/priv-app)
 - w LP czy dwa pierwsze od góry patch'e działają i co najważniejsze dla pewności test modowanego GP.

Pozdrawiam


Użytkownik chri5 edytował ten post 01 kwiecień 2015 - 13:27

  • 3

#2 Dychowski

Dychowski

    Owner

  • 6817 postów

Napisano 31 marzec 2015 - 12:37

Brawo kolego, takich ludzi życzyłbym temu forum więcej :-).

Pozdrawiam.


  • 0

#3 chri5

chri5

    Junior Member

  • 28 postów

Napisano 31 marzec 2015 - 12:42

Dzięki i Pozdrawiam :) być może to komuś pomoże, bo to jedyna opcja (możliwe, że tylko z tymi plikami ;) ) jaka pomogła mi.


  • 0

#4 Dychowski

Dychowski

    Owner

  • 6817 postów

Napisano 31 marzec 2015 - 12:46

Zapewne nie jednemu pomoże dlatego szacun dla Ciebie :-).

Pozdrawiam.


  • 0

#5 chri5

chri5

    Junior Member

  • 28 postów

Napisano 31 marzec 2015 - 12:55

To się okaże ;) lecz dobrze by było gdyby komuś pomogło. Mam nadzieję, że nie będą mnie wyklinać jak coś pojdzie znowu nie tak ;) Jeszcze raz pozdrawiam i narazie uciekam. Temat otwarty ;) :)


  • 0

#6 EdiMar

EdiMar

    Administrator

  • 1610 postów
  • LokalizacjaElbląg

Napisano 31 marzec 2015 - 19:24

Dzięki za podzielenie się wiedzą. Plusik poleciał.


  • 0

Jeżeli Ci pomogłem - kliknij zieloną strzałkę!;]


#7 Georgi84

Georgi84

    Member

  • 176 postów

Napisano 01 kwiecień 2015 - 10:31

Co prawda na Xperii M2... Po postawieniu nowego romu i zrobieniu Roota na androidzie 4.3 i 4.4.2 wystarcza spatchowanie w Lp dwóch pierwszych patchy że screena: f4dabcf3137177dbff53f4a508d4b001.jpg
Później trzeci patch ze screena bo odrazu trzech nie da rady zrobić, oczywiście po patchowaniu robi się automatycznie restart fona. Następnie instalujemy modowany market. I wszystko powinno śmigać.
U mnie ta procedura nie sprawiała żadnych problemów z późniejszym działaniem modowanego marketu.
W to gdzie znajduje się apka marketu nigdy nie wnikałem, zaktualizowany LP zawsze sobie radził.
  • 0

#8 chri5

chri5

    Junior Member

  • 28 postów

Napisano 01 kwiecień 2015 - 13:43

...a mówiłem, że będą pisać, ..."że to nie nowość lub że to już było..." :D

Tak, wiem, temat opisywany milion razy i na kilka sposobów... prawie tyle razy ;) ile instalowałem GP bez problemów.

 

Georgi84 Mi na 4.3 zawsze działała podmianka i nadanie 644 bez najmiejszych problemów. Nigdy nie instalowałem. Na poprzednich romach również zero problemów.
W 4.3 (JB) "Phonesky.apk" powinien znajdować się w "system/app", a w 4.4.2 (KK) w "system/priv-app".
To czy zawsze dokładnie sobie radził zależy od tego gdzie ulokował Phonesky. Chociaż może inna lokalizacja pliku (nawet przy stwierdzeniu poprawności w LP) nie robi problemu ;) aż tak nie wgłębiałem się w temat rozbijając LP na części pierwsze ;) więc nie jestem negatywnie nastawiony do tego w jaki sposób zrobiłeś to Ty :)
Mi na 4.4.4 przy instalacji przez LP jak i przy instalacji z installer,a w/g opisów z różnych forum zmieniał nazwe albo na "Vending.apk" albo na ...android.vending.apk i potrafił ulokować się nawet w system/app. I to właśnie na 4.4.4 gdzie wiadomo, że powinien posiadać inną nazwę i znajdować się gdzieś indziej.
Fakt, że w jednym z powyższych przypadków LP nawet wyświetlał, że wszystko ze sklepem jest OK. Moim zdaniem coś dziwnie rochę ;) Natomiast w przypadku wcześniejszego spaczowania w LP (poprzez zaznaczenie i restart jak i drugim spasobem przez ręcznie spaczowanie plikow core.jar i services.jar), restarcie, po podmiance pliku (wszystko jedno z kąd i jaka wersja) w system/priv-app, nadaniu praw i restarcie, tu stwierdzał, że jest zainstalowany lecz nie działa prawidłowo i że nie spaczowałem core.jar :wysmiewa:
 Ja tam wolę gdy jest tam gdzie być powinnien i nazywać się tak jak powinnien, więc nie zrezygnowałem i udało mi się w końcu zrobić to tak jak być powinno dzięki właśnie tej powyższej wersji installer'a i temu wyżej opisanemu sposobowi.

Może opisany przeze mnie sposób i zamieszczone w nim pliki, jak wspomiałem nie jest i nie będzie lekarstwem dla wszystkich ale umieściłem go dla tych osób, którzy mają lub będą posiadać taki sam problem jaki miałem ja.
Uwierz, że dużo ludzi ma z tym problem na 4.4.4, bądz będzie go mieć na 5.x.

 

Co do instalacji modowanego marketu to przed instalacją nic nie patch'owałem w Lucky Patcher ;)

 

Pozdrawiam


Użytkownik chri5 edytował ten post 01 kwiecień 2015 - 17:50

  • 0

#9 Dychowski

Dychowski

    Owner

  • 6817 postów

Napisano 01 kwiecień 2015 - 17:51

Nie patrz na detale, czym więcej info i szczegółowych opisów, tym lepiej i zawsze jest to mile widziane, nikt Cię tutaj z tego powodu z całą pewnością nie pogoni :-) a jak Cię pogoni, napisz mi PW jego nick :-).


  • 0

#10 Georgi84

Georgi84

    Member

  • 176 postów

Napisano 02 kwiecień 2015 - 17:14

Ja tylko opisałem sytuację na swoim telefonie, na SGS2 (4.1.2) procedura którą opisałem też działała. Nie było to "czepialstwo" z mojej strony;-)
  • 0

#11 chri5

chri5

    Junior Member

  • 28 postów

Napisano 08 kwiecień 2015 - 11:57

Georgi84 Wszystko OK każdy ma przecież prawo podzielić sie swoimi doświadczeniami :) Spoko ;)
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych